Microsoft Incident - Azure Resource Manager - Mitigated - Azure Resource Manager experiencing service management operations failures in West Europe

Incident Report for Graphisoft

Update

What happened?


Between 08:55 UTC and 09:40 UTC on 19 September 2025, a platform issue resulted in an impact to the Azure Resource Manager (ARM) service in the West Europe region. Impacted customers experienced failures when performing service management operations (such as create, delete, update, scaling, start, stop) for resources hosted in this region.




What do we know so far?


We determined this service event was caused by a transient issue in an internal component responsible for initiating API requests to our backend dependencies. This component encountered intermittent failures that interrupted the communication flow, resulting in API call timeouts and subsequent failure of service request processing. As a result, service operations could not be completed manifesting in impact mentioned above.




How did we respond?


  • 08:55 UTC on 19 September 2025 - Customer impact began.
  • 09:10 UTC on 19 September 2025 - Service monitoring detected a spike in failure rate and triggered an alert notifying us about service functionality disruption.
  • 09:20 UTC on 19 September 2025 - Transient issue within an internal component was identified as a contributing cause to this service event.
  • 09:25 UTC on 19 September 2025 - Auto-mitigation workstream was initiated by Azure platform, service recovery was monitored while the service self-healed.
  • 09:40 UTC on 19 September 2025 - Service restored, and customer impact confirmed fully mitigated.



What Happens Next?


  • Our team will be completing an internal retrospective to understand the incident in more detail. Once that is completed, generally within 14 days, we will publish a Post Incident Review (PIR) to all impacted customers.
  • To get notified when that happens, and/or to stay informed about future Azure service issues, make sure that you configure and maintain Azure Service Health alerts – these can trigger emails, SMS, push notifications, webhooks, and more: https://aka.ms/ash-alerts .
  • For more information on Post Incident Reviews, refer to https://aka.ms/AzurePIRs .
  • The impact times above represent the full incident duration, so are not specific to any individual customer. Actual impact to service availability may vary between customers and resources – for guidance on implementing monitoring to understand granular impact: https://aka.ms/AzPIR/Monitoring .
  • Finally, for broader guidance on preparing for cloud incidents, refer to https://aka.ms/incidentreadiness .

Posted Sep 19, 2025 - 14:12 CEST

Investigating

What happened?


Between 08:55 UTC and 09:25 UTC on 19 September 2025, a platform issue resulted in an impact to the Azure Resource Manager in West Europe region. Customers may have experienced receiving error notifications when performing service management operations - such as create, delete, update, scaling, start, stop - for resources hosted in this region.


 


This issue is now mitigated. An update with more information will be provided shortly.

Posted Sep 19, 2025 - 12:48 CEST